www.openvehicles.com:6869/api/

10 posts / 0 new
Last post
John@John-J.Link
www.openvehicles.com:6869/api/

When trying to access www.openvehicles.com:6869/api/ using a curl command I get "Authentication failed" even though the user name and password are correct. Has something on the server end changed?

dexter
dexter's picture
The REST API listens on port

The REST API listens on port 6868.

John@John-J.Link
I get this result for port

I get this result for port 6868.

root@raspberrypi:~/OVMS# curl -v -k -c cookiejar https://www.openvehicles.com:6868/api/cookie\?xxx\&password=xxx
* Trying 202.52.43.188...
* TCP_NODELAY set
* Connected to www.openvehicles.com (202.52.43.188) port 6868 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
* CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: /etc/ssl/certs
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
* Curl_http_done: called premature == 1
* stopped the pause stream!
* Closing connection 0
curl: (35) error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

dexter
dexter's picture
…and the V2 server REST API

…and the V2 server REST API does not support SSL, and your call is missing the username parameter.

John@John-J.Link
Is there any documentation or

Is there any documentation or samples for accessing the server data?
Thanks

dexter
dexter's picture
http://lists.openvehicles.com
dexter
dexter's picture
Note: the simpleclient page

Note: the simpleclient page has been removed from the current openvehicles.com site, so can currently only be used for cars on my server.

dexter
dexter's picture
Another note: SSL support is

Another note: SSL support is actually possible and would be on port 6869, but needs a certificate. I'll try to add this on my server.

dexter
dexter's picture
OK, SSL support is now
John@John-J.Link
Yes, it working now. Thank

Yes, it working now. Thank you!

Log in or register to post comments